use strict;
my $str = ' //wont won\'t won\'t ';
my $regex = qr~[\s+/,.!_\-?;:]+|\B'|'\B~mp;
my $subst = '\\n';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";