re = /[\s+\/,.!_\-?;:]+|\B'|'\B/m
str = ' //wont won\'t won\'t '
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result