import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?\\d+\\.?\\d*?([1-9].*?|0[1-9].*?|0$)";
final String string = "2.001469, should be trimmed to 2.001\n"
+ "15 should stay as it is, since it has no decimals\n"
+ "-7.00000046598 should be trimmed to -7.0000004\n"
+ "15.135 should be trimmed to 15.1\n"
+ "0.00004123456\n"
+ ".1538";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}