import Foundation
let pattern = #"^-?\d+\.?\d*?([1-9].*?|0[1-9].*?|0$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2.001469, should be trimmed to 2.001
15 should stay as it is, since it has no decimals
-7.00000046598 should be trimmed to -7.0000004
15.135 should be trimmed to 15.1
0.00004123456
.1538
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)