$re = '/^-?\d+\.?\d*?([1-9].*?|0[1-9].*?|0$)/m';
$str = '2.001469, should be trimmed to 2.001
15 should stay as it is, since it has no decimals
-7.00000046598 should be trimmed to -7.0000004
15.135 should be trimmed to 15.1
0.00004123456
.1538';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);