import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^\\w+)(?:9|8)\\d{8}";
final String string = "\n"
+ "999999999\n\n"
+ "999999999\n\n"
+ "999999999\n\n"
+ "99999999999999999\n\n"
+ "999999999\n"
+ "!999999999\n"
+ "! 999999999\n\n"
+ "999999999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}