$re = '/(?=^\w+)(?:9|8)\d{8}/m';
$str = '
999999999
999999999
999999999
99999999999999999
999999999
!999999999
! 999999999
999999999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);