import re
regex = re.compile(r"(?=^\w+)(?:9|8)\d{8}", flags=re.MULTILINE)
test_str = ("\n"
"999999999\n\n"
"999999999\n\n"
"999999999\n\n"
"99999999999999999\n\n"
"999999999\n"
"!999999999\n"
"! 999999999\n\n"
"999999999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")