re = /(?=^\w+)(?:9|8)\d{8}/m
str = '
999999999
999999999
999999999
99999999999999999
999999999
!999999999
! 999999999
999999999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end