#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=\<article\>)([\s\S]*)(?=\<\/article>)"
Local $sString = "<article>" & @CRLF & _
"html stuff here html stuff here html stuff here html stuff here" & @CRLF & _
"html stuff here html stuff here html stuff here html stuff here" & @CRLF & _
"</article>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")