const regex = /(?<=\<article\>)([\s\S]*)(?=\<\/article>)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\<article\\>)([\\s\\S]*)(?=\\<\\\/article>)', 's')
const str = `<article>
html stuff here html stuff here html stuff here html stuff here
html stuff here html stuff here html stuff here html stuff here
</article>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}