$re = '/(?<=\<article\>)([\s\S]*)(?=\<\/article>)/s';
$str = '<article>
html stuff here html stuff here html stuff here html stuff here
html stuff here html stuff here html stuff here html stuff here
</article>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);