re = /(?<=\<article\>)([\s\S]*)(?=\<\/article>)/
str = '<article>
html stuff here html stuff here html stuff here html stuff here
html stuff here html stuff here html stuff here html stuff here
</article>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end