using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)?(?:$|(.+?)(?:(\.[^.]*$)|$))";
string input = @"EBS/FSW/VehISp/VehISp_generic/TCY/Src/tcy_main.c
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}