$re = '/^(.*)?(?:$|(.+?)(?:(\.[^.]*$)|$))/';
$str = 'EBS/FSW/VehISp/VehISp_generic/TCY/Src/tcy_main.c
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);