re = /^(.*)?(?:$|(.+?)(?:(\.[^.]*$)|$))/
str = 'EBS/FSW/VehISp/VehISp_generic/TCY/Src/tcy_main.c
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end