package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.*)?(?:$|(.+?)(?:(\.[^.]*$)|$))`)
var str = `EBS/FSW/VehISp/VehISp_generic/TCY/Src/tcy_main.c
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}