using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhref=""((?:http|ftp)[^""]+)""";
string input = @"href=""http://mylink.com/""
href=""http://mylink2.com/""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}