package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bhref="((?:http|ftp)[^"]+)"`)
var str = `href="http://mylink.com/"
href="http://mylink2.com/"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}