re = /\bhref="((?:http|ftp)[^"]+)"/
str = 'href="http://mylink.com/"
href="http://mylink2.com/"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end