$re = '/\bhref="((?:http|ftp)[^"]+)"/';
$str = 'href="http://mylink.com/"
href="http://mylink2.com/"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);