#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?P<Namespace>.+?)::)?(?P<Group>[^.]+).(?P<Item>.+)$"
Local $sString = "cache.levels.expensive.drivers" & @CRLF & _
"namespace::cache.levels.expensive.drivers" & @CRLF & _
"database.user" & @CRLF & _
"concrete.debug.display_errors" & @CRLF & _
"core::concrete.debug.display_errors"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")