package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?P<Namespace>.+?)::)?(?P<Group>[^.]+).(?P<Item>.+)$`)
var str = `cache.levels.expensive.drivers
namespace::cache.levels.expensive.drivers
database.user
concrete.debug.display_errors
core::concrete.debug.display_errors`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}