re = /^(?:(?P<Namespace>.+?)::)?(?P<Group>[^.]+).(?P<Item>.+)$/m
str = 'cache.levels.expensive.drivers
namespace::cache.levels.expensive.drivers
database.user
concrete.debug.display_errors
core::concrete.debug.display_errors'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end