$re = '/^(?:(?P<Namespace>.+?)::)?(?P<Group>[^.]+).(?P<Item>.+)$/m';
$str = 'cache.levels.expensive.drivers
namespace::cache.levels.expensive.drivers
database.user
concrete.debug.display_errors
core::concrete.debug.display_errors';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);