#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<td[^>]*>\s*(?:.(?!</td>))+\s*<\?php audioButton\("[^"]*/(.+?)","(.*?)"\);.*?\?>.*?</td>"
Local $sString = "<td class="danish">kat" & @CRLF & _
"<?php audioButton("../../audio/words/dog","dog");?></td>" & @CRLF & _
"" & @CRLF & _
"<td class="danish">kat" & @CRLF & _
"<?php audioButton("../../audio/words/dog","dog");?></td>" & @CRLF & _
"" & @CRLF & _
"<td class="danish">kat</td>" & @CRLF & _
"<td><?php audioButton("../../audio/words/dog","dog");?></td>" & @CRLF & _
"" & @CRLF & _
"<td class="danish">kat" & @CRLF & _
"<?php audioButton("../../audio/words/dog","dog");?></td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")