const regex = new RegExp('<td[^>]*>\\s*(?:.(?!</td>))+\\s*<\\?php audioButton\\("[^"]*/(.+?)","(.*?)"\\);.*?\\?>.*?</td>', 'g')
const str = `<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat</td>
<td><?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}