using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td[^>]*>\s*(?:.(?!</td>))+\s*<\?php audioButton\(""[^""]*/(.+?)"",""(.*?)""\);.*?\?>.*?</td>";
string input = @"<td class=""danish"">kat
<?php audioButton(""../../audio/words/dog"",""dog"");?></td>
<td class=""danish"">kat
<?php audioButton(""../../audio/words/dog"",""dog"");?></td>
<td class=""danish"">kat</td>
<td><?php audioButton(""../../audio/words/dog"",""dog"");?></td>
<td class=""danish"">kat
<?php audioButton(""../../audio/words/dog"",""dog"");?></td>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}