import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\W*=\\W*['\"].+?(?!\\\\)['\"],";
final String string = "INSERT INTO cms_download_history\n"
+ "SET\n"
+ "user_id = '{$userId}',\n"
+ "download_id = '{$fileId}',\n"
+ "remote_addr = '{$remote_addr}',\n"
+ "doa = GetDate()\";";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}