$re = '/(\w+)\W*=\W*[\'"].+?(?!\\\\)[\'"],/';
$str = 'INSERT INTO cms_download_history
SET
user_id = \'{$userId}\',
download_id = \'{$fileId}\',
remote_addr = \'{$remote_addr}\',
doa = GetDate()";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);