const regex = /(\w+)\W*=\W*['"].+?(?!\\)['"],/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\W*=\\W*[\'"].+?(?!\\\\)[\'"],', 'g')
const str = `INSERT INTO cms_download_history
SET
user_id = '{\$userId}',
download_id = '{\$fileId}',
remote_addr = '{\$remote_addr}',
doa = GetDate()";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}