re = /(\w+)\W*=\W*['"].+?(?!\\)['"],/
str = 'INSERT INTO cms_download_history
SET
user_id = \'{$userId}\',
download_id = \'{$fileId}\',
remote_addr = \'{$remote_addr}\',
doa = GetDate()";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end