package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(?:[^][]|(?R))*\]`)
var str = `viel Text drumherum
[abc, 12
[345]
[yxz]
] ...
noch in der nächsten Zeile
[weiter]
und Ende`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}