re = /\[(?:[^][]|(?R))*\]/
str = 'viel Text drumherum
[abc, 12
[345]
[yxz]
] ...
noch in der nächsten Zeile
[weiter]
und Ende'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end