import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?:[^][]|(?R))*\\]";
final String string = "viel Text drumherum\n"
+ "[abc, 12\n"
+ " [345]\n"
+ " [yxz]\n"
+ "] ...\n"
+ "noch in der nächsten Zeile\n"
+ "[weiter]\n"
+ "und Ende";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}