using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*thank(\-|\_|)you.*";
string input = @"/thank-you/
/free-estimate/?thank_you=true
/estimate-request/?thank_you=true
/free-estimate/offer1/thank-you.html
/free-estimate/offer2/thank-you.html";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}