import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*thank(\\-|\\_|)you.*";
final String string = "/thank-you/\n"
+ "/free-estimate/?thank_you=true\n"
+ "/estimate-request/?thank_you=true\n"
+ "/free-estimate/offer1/thank-you.html\n"
+ "/free-estimate/offer2/thank-you.html";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}