import re
regex = re.compile(r".*thank(\-|\_|)you.*")
test_str = ("/thank-you/\n"
"/free-estimate/?thank_you=true\n"
"/estimate-request/?thank_you=true\n"
"/free-estimate/offer1/thank-you.html\n"
"/free-estimate/offer2/thank-you.html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")