$re = '/.*thank(\-|\_|)you.*/';
$str = '/thank-you/
/free-estimate/?thank_you=true
/estimate-request/?thank_you=true
/free-estimate/offer1/thank-you.html
/free-estimate/offer2/thank-you.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);