using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"- .*?\[ACTIVE\] Execute(Thread:\s+'[^']*').*-";
string substitution = @"\1";
string input = @"<2015-01-22 10:23:51,000> - <DEBUG> - <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> - MyLogClass - Message1
<2015-01-22 10:23:52,000> - <INFO> - <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> - MyLogClass - Message2
<2015-01-22 10:23:53,000> - <ERROR> - <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> - MyLogClass - Message3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}