// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)- .*?\[ACTIVE\] Execute(Thread:\s+'[^']*').*-").unwrap();
let string = "<2015-01-22 10:23:51,000> - <DEBUG> - <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> - MyLogClass - Message1
<2015-01-22 10:23:52,000> - <INFO> - <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> - MyLogClass - Message2
<2015-01-22 10:23:53,000> - <ERROR> - <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> - MyLogClass - Message3";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}