re = /- .*?\[ACTIVE\] Execute(Thread:\s+'[^']*').*-/m
str = '<2015-01-22 10:23:51,000> - <DEBUG> - <[ACTIVE] ExecuteThread: \'1\' for queue: \'weblogic.kernel.Default (self-tuning)\'> - MyLogClass - Message1
<2015-01-22 10:23:52,000> - <INFO> - <[ACTIVE] ExecuteThread: \'2\' for queue: \'weblogic.kernel.Default (self-tuning)\'> - MyLogClass - Message2
<2015-01-22 10:23:53,000> - <ERROR> - <[ACTIVE] ExecuteThread: \'2\' for queue: \'weblogic.kernel.Default (self-tuning)\'> - MyLogClass - Message3'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result