import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "- .*?\\[ACTIVE\\] Execute(Thread:\\s+'[^']*').*-";
final String string = "<2015-01-22 10:23:51,000> - <DEBUG> - <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> - MyLogClass - Message1\n"
+ "<2015-01-22 10:23:52,000> - <INFO> - <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> - MyLogClass - Message2\n"
+ "<2015-01-22 10:23:53,000> - <ERROR> - <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> - MyLogClass - Message3";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}