import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z-'/, ]{0,25}$|^_$";
final String string = "ab-abc\n"
+ "-\n"
+ "hello \n"
+ "abc-'/ citizen\n"
+ "john citizen\n"
+ "abcdefghijklmnopqrstuvwxy\n"
+ "abcdefghijklmnopqrstuvwxy\n"
+ " \n\n"
+ "abc&\n"
+ "_\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}