$re = '/^[a-zA-Z-\'/, ]{0,25}$|^_$/ms';
$str = 'ab-abc
-
hello
abc-\'/ citizen
john citizen
abcdefghijklmnopqrstuvwxy
abcdefghijklmnopqrstuvwxy
abc&
_
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);