re = /^[a-zA-Z-'\/, ]{0,25}$|^_$/m
str = 'ab-abc
-
hello
abc-\'/ citizen
john citizen
abcdefghijklmnopqrstuvwxy
abcdefghijklmnopqrstuvwxy
abc&
_
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end