// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)^[a-zA-Z-'/, ]{0,25}$|^_$").unwrap();
let string = "ab-abc
-
hello
abc-'/ citizen
john citizen
abcdefghijklmnopqrstuvwxy
abcdefghijklmnopqrstuvwxy
abc&
_
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}