#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^\x3a(:?(\[\w+\])?(\[\s\w+\s\]?)?)?\s?(\w+)"
Local $sString = ":[ Admin ] User_name" & @CRLF & _
":[gold][ Admin ] User_name" & @CRLF & _
":[gold]User_name" & @CRLF & _
":[gold][ Admin ] user_name" & @CRLF & _
":User_name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")