$re = '/^\x3a(:?(\[\w+\])?(\[\s\w+\s\]?)?)?\s?(\w+)/im';
$str = ':[ Admin ] User_name
:[gold][ Admin ] User_name
:[gold]User_name
:[gold][ Admin ] user_name
:User_name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);