package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^\x3a(:?(\[\w+\])?(\[\s\w+\s\]?)?)?\s?(\w+)`)
var str = `:[ Admin ] User_name
:[gold][ Admin ] User_name
:[gold]User_name
:[gold][ Admin ] user_name
:User_name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}